We currently refer to individual language analyzers as 'products': SonarKotlin, but they are not and have never been products. They are benefits delivered by SonarQube, SonarLint, and SonarCloud. Let's eliminate uses of 'SonarKotlin' to remove confusion. Specifically in
- embedded docs & README.md. Use instead:
- title "Code Quality and Security for Kotlin'
- in text: 'analysis of Kotlin'
- the Marketplace display name (pluginName). Use instead:
- 'Kotlin Code Quality and Security'