Uploaded image for project: 'SonarQube Plugins'
  1. SonarQube Plugins
  2. SONARPLUGINS-606

Sources were not shown if //NOPMD tag is in the first row

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: TAGLIST-0.7
    • Fix Version/s: TAGLIST-1.0
    • Component/s: TagList
    • Labels:
      None
    • Environment:
      Win XP/Linux x32, JRE 1.5.0_11, MySQL

      Description

      When i tried to list all //NOPMD tags, i've noticed, that there is no sources be shown. It happens in all files where //NOPMD tag is in the first row:

      SxOrderOverviewPanel.java
      // Some comments here
      package stox.gui.client; // NOPMD we need so much imports because we do not use .* and use static imports
      
      import basic.gui.components.JComponentFactory;
      import basic.gui.components.JTableEnhanced;
      ...
      

      I also tried to put the tag to the second row and it works like it have to.

      1. coverage.jpg
        81 kB
      2. violations.jpg
        84 kB

        Activity

        akit Alexander Krist added a comment -

        But if the tag is in the second line it doesn't have funktional anymore.

        godin OLD - Evgeny Mandrikov added a comment -

        Hi Alexander,

        I've reproduced this issue with Sonar 2.4 and Sonar Taglist Plugin 0.7. And I can say that this issue definitely relates to taglist-maven-plugin , because in this case report generated by maven plugin contains wrong name of file - see MTAGLIST-48.

        But also I have a good news - there is no such problem in next version of Sonar Taglist Plugin , because it doesn't use maven plugin any more (see SONARPLUGINS-804).


          People

          • Assignee:
            godin OLD - Evgeny Mandrikov
            Reporter:
            akit Alexander Krist
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: