Uploaded image for project: 'Java'
  1. Java
  2. SONARJAVA-44

The IT and Overall code coverage should not be computed when the code coverage by unit tests is not computed with jacoco

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1
    • Component/s: JaCoCo
    • Labels:
      None

      Description

      for the time being overall code coverage = integration test coverage

        Activity

        freddy.mallet Freddy Mallet added a comment -

        Manually tested !

        sam.hendley sam hendley added a comment -

        I was about to post a bug about "Overall coverage" not being calculated if there is no Unit coverage when I found this. Is that expected behavior? I think it leads to odd results if we dont consider a package with only integration testing to have an "overall coverage" number.

        sam.hendley sam hendley added a comment -

        Here is a link to what it looks like now:

        http://imgur.com/IlHyAxN


          People

          • Assignee:
            dgageot David Gageot
            Reporter:
            freddy.mallet Freddy Mallet
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: