Uploaded image for project: 'SonarJava'
  1. SonarJava
  2. SONARJAVA-1091

JaCoCo 0.7.5 produces binary reports that are not compatible with previous version (0.7.4)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.3
    • Fix Version/s: 3.4
    • Component/s: JaCoCo
    • Labels:
      None

      Description

      This results in failure of the analysis with the following error message:

      Caused by: java.io.IOException: Incompatible version 1007.
      12:12:54 	at org.jacoco.core.data.ExecutionDataReader.readHeader(ExecutionDataReader.java:127)
      12:12:54 	at org.jacoco.core.data.ExecutionDataReader.readBlock(ExecutionDataReader.java:107)
      12:12:54 	at org.jacoco.core.data.ExecutionDataReader.read(ExecutionDataReader.java:87)
      12:12:54 	at org.sonar.plugins.jacoco.JaCoCoOverallSensor.loadSourceFiles(JaCoCoOverallSensor.java:124)
      

        Issue Links

          Activity

          michael.gumowski Michael Gumowski added a comment -

          Manually tested with jacoco 0.7.4 and 0.7.5. LGTM!

          [INFO] [11:00:52.199] Sensor JaCoCoOverallSensor
          [WARN] [11:00:52.209] You are not using the latest JaCoCo binary format version, please consider upgrading to latest JaCoCo version.
          [INFO] [11:00:52.209] Analysing c:\dev\workspaces\eclipse\HeadShot\target\jacoco.exec
          [WARN] [11:00:52.222] You are not using the latest JaCoCo binary format version, please consider upgrading to latest JaCoCo version.
          [INFO] [11:00:52.222] Analysing c:\dev\workspaces\eclipse\HeadShot\target\sonar\jacoco-overall.exec
          [INFO] [11:00:52.260] No information about coverage per test.
          [INFO] [11:00:52.260] Sensor JaCoCoOverallSensor (done) | time=61ms
          [INFO] [11:00:52.260] Sensor SCM Sensor
          [INFO] [11:00:52.266] No SCM system was detected. You can use the 'sonar.scm.provider' property to explicitly specify it.
          [INFO] [11:00:52.271] Sensor SCM Sensor (done) | time=11ms
          [INFO] [11:00:52.277] Sensor JaCoCoSensor
          [WARN] [11:00:52.283] You are not using the latest JaCoCo binary format version, please consider upgrading to latest JaCoCo version.
          [INFO] [11:00:52.288] Analysing c:\dev\workspaces\eclipse\HeadShot\target\jacoco.exec
          [INFO] [11:00:52.302] Information about coverage per test has been collected.
          [INFO] [11:00:52.303] Sensor JaCoCoSensor (done) | time=26ms
          
          kevinc@stytch.com Kevin Chen added a comment -

          I can't add a new issue so I'm commenting on this one. We're having a problem running the gradle sonarqube plugin on gradle 2.13 due to this same error being generated. We created a stackoverflow entry. Any help would be appreciated.

          https://stackoverflow.com/questions/37149400/gradle-sonarqube-plugin-fails-with-incompatible-version-1007-with-gradle-versi

          nicolas.peru Nicolas Peru added a comment -

          Kevin Chen As jira is our backlog, indeed we keep the control over creation of issues. We are closely monitoring stackoverflow question (as mentioned here : http://www.sonarqube.org/get-support/) so there is no need to comment on old closed ticket, we will answer you on stackoverflow. Thanks.

          nicolas.peru Nicolas Peru added a comment -

          (By the way, your question need more precisions, I asked them in a comment on stackoverflow).


            People

            • Assignee:
              nicolas.peru Nicolas Peru
              Reporter:
              benzonico OLD - Nicolas Peru
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved: