Details

    • Type: Improvement
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.6
    • Component/s: None
    • Labels:
      None

      Description

      Seems there are some API changes coming in the Android Gradle Plugin 3.0.0:

      java.lang.NoSuchMethodError: com.android.build.gradle.api.ApkVariant.getCompileLibraries()Ljava/util/Collection;
              at org.sonarqube.gradle.AndroidUtils.populateSonarQubeProps(AndroidUtils.java:214)
              at org.sonarqube.gradle.AndroidUtils.configureForAndroid(AndroidUtils.java:73)
              at org.sonarqube.gradle.AndroidUtils.configureForAndroid(AndroidUtils.java:63)
              at org.sonarqube.gradle.SonarQubePlugin.computeSonarProperties(SonarQubePlugin.java:384)
              at org.sonarqube.gradle.SonarQubePlugin.computeSonarProperties(SonarQubePlugin.java:418)
      

      This was with version 3.0.0-alpha3, let wait for the final release before taking any decision.

      Reported upstream: https://issuetracker.google.com/issues/62688864

      Update: confirmed this is an intended change. We should use instead:

      variant.getCompileClasspath(null)
      

        Attachments

          Activity

            People

            • Assignee:
              julien.henry Julien Henry
              Reporter:
              julien.henry Julien Henry
            • Votes:
              9 Vote for this issue
              Watchers:
              18 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved: