Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-9979

Fix potential vulnerability in plugins built with API <= 5.2

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.7
    • Component/s: None
    • Labels:
      None

      Description

      Apache Commons BeanUtils 1.8 suffers from the vulnerability CVE-2014-0114.

      SonarQube core is not impacted because it does not use this library.
      However the plugins built with sonar-plugin-api 5.2 or lower have a special classpath that contains this version of BeanUtils. As a consequence they may face the vulnerability.

      Note that plugins built with the API 5.3+ have their own isolated classpath. It's their responsibility to upgrade BeanUtils if needed.

        Attachments

          Activity

            People

            Assignee:
            simon.brandhof Simon Brandhof (Inactive)
            Reporter:
            simon.brandhof Simon Brandhof (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Due:
              Created:
              Updated:
              Resolved: