We are generally using a common naming convention for the metrics that apply to the Leak Period: '... on New Code'.
But the metrics about issues are named 'New...', and "Lines on New Code" introduced by
MMF-295 looks weird as it tries to match the convention.
- Some metrics really apply on new code such as Line Coverage, Technical Debt Ratio.. but when we are talking about really added or updated lines/conditions, we could use "New...":
- New uncovered lines
- New uncovered conditionns
- New lines to cover
- New duplicated lines
- New duplicated blocks
- New lines
- The wording "New..." is currently used for issues only. We could keep that exception and, as an alternative, simply rename "Lines on New Code" to "Lines of New Code". We would then stay close to our current convention but be more syntactically correct.
- (The preferred one at the time being)
As part of
MMF-473, all the differential metrics should always apply to the leak period.
We could then rename all those metrics from 'New...' and '.. on New Code' to '... on Leak Period Code' or '.. in the Leak'.