Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-7587

Both Server and Scanner must fail if not started on Java 8+

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.6
    • Component/s: Scanner
    • Labels:

      Description

      Plugins will be able to start using Java 8 once they upgraded their dependency to SonarQube 5.6. This means that at any point of time, if someone runs SQ 5.6 on Java 7 without noticing this, there's one day when the instance will be broken once a Java8-based plugin will be installed.
      For this reason, it's best to fail fast and:

      • Make sure that the SonarQube instance fails with a gentle message at startup if not running on Java 8+
      • Same on scanner side

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              simon.brandhof Simon Brandhof (Inactive)
              Reporter:
              fabrice.bellingard Fabrice Bellingard
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Due:
                Created:
                Updated:
                Resolved: