Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-7574

Authorize to set log level to WARN or ERROR in API for embedded 3rd party library

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.7
    • Component/s: Plugin API
    • Labels:

      Description

      The API does not allow to set a logger at level WARNING or ERROR. This is a valid use case as described in the Javadoc.

      It should be possible to customize the logger of an embedded 3rd party library.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                eric.hartmann Eric Hartmann
                Reporter:
                teryk.bellahsene Teryk Bellahsene (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: