Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-7126

Scanner on Java 7 must support TLS 1.2 when connecting to SonarQube HTTPS server

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.3
    • Component/s: Scanner
    • Labels:
      None

      Description

      Only TLS 1.0 is enabled by default on Java 7. It prevents scanner from reaching a SonarQube HTTPS server using TLS 1.2.
      Note that this constraint does not exist with Java 8 as all TLS versions are enabled by default.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              simon.brandhof Simon Brandhof (Inactive)
              Reporter:
              simon.brandhof Simon Brandhof (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Due:
                Created:
                Updated:
                Resolved: