The word "component" is reserved to objects of the project tree (project, module, directories, files).
But it was previously used to identify objects that are injected into SonarQube IoC container. To avoid confusion the two marker interfaces BatchComponent and ServerComponent should be replaced.
Proposal: use annotations
- BatchComponent -> @BatchSide
- ServerComponent -> @ServerSide
- Extension -> @ExtensionPoint
- BatchExtension -> @BatchSide + @ExtensionPoint
- ServerExtension -> @ServerSide + @ExtensionPoint