Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-5575

Editing parameters of a custom rule does not work correctly

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.4
    • Fix Version/s: 4.5.1
    • Component/s: Rules
    • Labels:
      None

      Description

      Here are the use cases that don't work:

      1. Empty parameters
        • Create a custom rule based on the "Architectural Constraints" rule, with an empty parameter for "fromClasses"
        • Issue #1: when displaying the custom rule, the parameter is not displayed
        • Issue #2: when editing the custom rule, the parameter is not available
        • => Check this rule on Dory VM
      2. Parameters with special characters
        • Create a custom rule based on the Java "XPath" rule, with an XPath set to something like what is given on this Gist
        • Same Issues as first point
        • => See this thread and this one on the user ML
      3. Impossible to set an optional parameter to a blank value if it has already been set
        • Create a custom rule based on the "Architectural Constraints" rule, with non empty "fromClasses" parameter
        • Issue: removing the value for this parameter (=setting it to blank) is not possible

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jb.lievremont OLD - Jean-Baptiste Lièvremont (Inactive)
              Reporter:
              fabemn OLD - Fabrice Bellingard
              Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Due:
                Created:
                Updated:
                Resolved: