Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-4640

Make warning for embedded DB more prominent, explicit

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.1
    • Component/s: Web
    • Labels:
      None

      Description

      There is already a warning in the footer when you're using the embedded database, but it's apparently easy to miss because the frequency of people running production on the embedded DB and/or wailing when they realize they can't migrate their data out of it is higher than it should be.

      So make that warning bigger and put it in red. Add to it something along the lines of:

      "The embedded database will not scale, it will not support upgrading to newer versions of SonarQube, and there is no support for migrating your data out of it into a different database engine."

        Attachments

          Activity

            People

            Assignee:
            stas.vilchik Stas Vilchik (Inactive)
            Reporter:
            ganncamp OLD - GAC
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Due:
              Created:
              Updated:
              Resolved: