Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-3686

Highlight the installed plugins that are not compatible with current SQ version

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Marketplace
    • Labels:
      None
    • Edition:
      Community

      Description

      The tab "Installed Plugins" of update center does not check if plugins are still compatible with the version of sonar. It can occur when a compatibility is broken, for instance :

      1. devcockpit 1.0 is installed on sonar 3.1
      2. devcockpit 1.0 is not compatible with sonar 3.2 and must be upgraded to 1.1
      3. sonar 3.1 is upgraded to 3.2 without using update center -> recommendation to upgrade devcockpit is not respected.
      4. sonar 3.2 is started with devcockpit 1.0 -> failure

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              simon.brandhof Simon Brandhof (Inactive)
              Votes:
              2 Vote for this issue
              Watchers:
              10 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: