Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-3516

Check minimal sonar version required by installed plugins

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2
    • Component/s: Marketplace
    • Labels:
      None

      Description

      Plugin manifest declares the minimal required version of sonar. This version should be verified at server startup. It prevents plugins from failing for API incompatibility reasons.
      The plugin should not be ignored. Startup must fail with a meaningful message.

        Attachments

          Activity

            People

            Assignee:
            dgageot David Gageot
            Reporter:
            simon.brandhof Simon Brandhof (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: