Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-3032

When the "Redundant Throws" Checkstyle check can't manage to get a class information, a runtime exception is thrown and the analysis of this file is stopped

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Component/s: None
    • Labels:
      None
    1. sonar-2.12.png
      20 kB
    2. sonar-2.13.png
      32 kB

      Issue Links

        Activity

        freddy.mallet Freddy Mallet created issue -
        freddy.mallet Freddy Mallet made changes -
        Field Original Value New Value
        Assignee Freddy Mallet [ freddy.mallet ]
        godin OLD - Evgeny Mandrikov made changes -
        Assignee Evgeny Mandrikov [ godin ]
        godin OLD - Evgeny Mandrikov added a comment - - edited

        Seems that behaviour of this check has been changed after migration to Checkstyle 5.5 (SONAR-1836), i.e. I can't reproduce this issue in Sonar 2.13.

        godin OLD - Evgeny Mandrikov made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        racodond David Racodon added a comment -

        You seem to confirm what we thought. See http://markmail.org/message/rvgjbykdalhyu4p4

        godin OLD - Evgeny Mandrikov added a comment -

        I just confirm that behaviour was changed, however would be better to understand how I'll come back to this thread tomorrow.

        godin OLD - Evgeny Mandrikov made changes -
        Attachment SONAR-3032.zip [ 59342 ]
        godin OLD - Evgeny Mandrikov made changes -
        Link This issue relates to SONAR-1836 [ SONAR-1836 ]
        godin OLD - Evgeny Mandrikov made changes -
        Attachment sonar-2.12.png [ 59344 ]
        Attachment sonar-2.13.png [ 59343 ]
        godin OLD - Evgeny Mandrikov added a comment -

        Here is an explanation of changes from release notes for Checkstyle 5.3 :

        Changed the default value of the property logLoadErrors to be true for the checks RedundantThrows and JavadocMethod to ensure consistent behaviour.

        Which means that violation will be shown, when Checkstyle is unable to load class, and processing of file will continue.
        Also should be noted that Sonar doesn't allow to change value of this property, because it isn't presented in rules.

        godin OLD - Evgeny Mandrikov added a comment - - edited

        I've added parameter "suppressLoadErrors" with default value "true" to Checkstyle rules "RedundantThrows" and "JavadocMethod" in order to not produce false-positive violations - 7d5b618. Also should be noted that default value for this parameter in Checkstyle 5.5 set to false.

        godin OLD - Evgeny Mandrikov made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Assignee Evgeny Mandrikov [ godin ] Freddy Mallet [ freddy.mallet ]
        Fix Version/s 2.15 [ 18255 ]
        Resolution Fixed [ 1 ]
        freddy.mallet Freddy Mallet added a comment -

        Manually tested

        freddy.mallet Freddy Mallet made changes -
        Assignee Freddy Mallet [ freddy.mallet ] Evgeny Mandrikov [ godin ]
        freddy.mallet Freddy Mallet made changes -
        Link This issue is duplicated by SONAR-1746 [ SONAR-1746 ]
        godin OLD - Evgeny Mandrikov added a comment -

        Integration test added.

        godin OLD - Evgeny Mandrikov made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        freddy.mallet Freddy Mallet made changes -
        Link This issue is related to SONAR-3502 [ SONAR-3502 ]
        fabemn OLD - Fabrice Bellingard made changes -
        Component/s Checkstyle [ 13818 ]
        hgomez Henri Gomez made changes -
        Project Import Wed May 27 13:41:49 CEST 2015 [ 1432726909095 ]
        henri.gomez Henri Gomez made changes -
        Project Import Thu May 28 19:38:02 UTC 2015 [ 1432841882590 ]
        freddy.mallet Freddy Mallet made changes -
        Workflow jira [ 27638 ] Default SonarSource Workflow [ 53144 ]
        freddy.mallet Freddy Mallet made changes -
        Workflow Default SonarSource Workflow [ 53144 ] Default Agile SonarSource Workflow [ 73362 ]

          People

          • Assignee:
            godin OLD - Evgeny Mandrikov
            Reporter:
            freddy.mallet Freddy Mallet
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: