Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-14951

Scanners require Java 11

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 9.0
    • Component/s: Scanner
    • Labels:
      None
    • Edition:
      Community
    • Production Notes:
      None

      Description

      The SonarQube server already requires Java 11.
      Now we'll migrate the scanner-engine to Java 11, forcing all scanners pointing to SonarQube to run with Java 11.
      This change will also allow us to migrate most modules of SonarQube to Java 11, with a few exceptions. Some modules need to stay with java 8 because they are used by SonarLint, which still runs with Java 8:

      • sonar-plugin-api
      • sonar-classloader
      • sonar-ws (only protobuf stubs)
      • sonar-markdown
      • sonar-scanner-protocol (only protobuf stubs)

        Attachments

          Activity

            People

            Assignee:
            duarte.meneses Duarte Meneses
            Reporter:
            duarte.meneses Duarte Meneses
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Due:
              Created:
              Updated:
              Resolved: