Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-14928

Improve JavaScript/TypeScript analysis - Support for TypeScript 4.3, 1 new security rule

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 9.0
    • Component/s: None
    • Edition:
      Community
    • Production Notes:
      None

      Description

      The JavaScript and TypeScript analysis brings:

      • the support for TypeScript 4.3
      • 1 new security rule: S6268 Disabling Angular built-in sanitization is security-sensitive

      The custom rule API which was previously deprecated is now removed. Plugins can no longer use this API to implement custom rules.
      As a replacement, we suggest to write rules for ESLint and use external issues import to make them appear in SonarQube.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              sonarqube.tech SonarQube Technical user
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: