Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-11878

Timeout when loading batch/project is ignored and lead to unexpected results

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 6.7.5
    • Fix Version/s: 6.7.7, 7.8
    • Component/s: Scanner
    • Labels:
      None
    • Edition:
      Community
    • Production Notes:
      None

      Description

      When the scanner load project repositories (batch/project WS) it should not fail when receiving a 404 since it simply means this is a new project, and that autoprovisionning should happen (with default quality profile).

      But it seems timeout and other errors are also ignored. The WS may take a while to respond for big projects, and it leads to analyzing the project with the default quality profile:

      21:46:29.681 INFO: Load project repositories
      21:47:39.952 DEBUG: Project repository not available - continuing without it
      21:47:43.556 INFO: Load project repositories (done) | time=73875ms
      

      (default timeout is 60s)

      Except if we are missing something here, only 404 and 200 should allow the analysis to continue.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                michal.duda Michal Duda
                Reporter:
                julien.henry Julien Henry
              • Votes:
                1 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: