Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-10668

Drop support of PostgreSQL versions lower than 9.3

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.3
    • Component/s: Database
    • Labels:
      None

      Description

      According to https://en.wikipedia.org/wiki/PostgreSQL#History:

      • 8.4 is the latest of the series 8.x. It reached end of life in July 2014.
      • 9.3 is the lowest version of series 9.x which is still "alive"

      As a consequence PostgreSQL 9.2 and lower should not be longer supported by SonarQube. Server should fail at startup.

        Attachments

          Activity

            People

            • Assignee:
              simon.brandhof Simon Brandhof
              Reporter:
              simon.brandhof Simon Brandhof
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved: