Uploaded image for project: 'SonarQube'
  1. SonarQube
  2. SONAR-10256

Display disabled "Update" button for plugin updates requiring newer SQ version

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Marketplace, Web
    • Labels:
      None
    • Estimate:
      Minutes
    • Edition:
      Community

      Description

      When there is a plugin update, but it's incompatible with the currently used SQ version, there is no "Update" button. The only chance to understand why is to put the mouse over the orange version badge to see "Requires system update". This might be not enough.

      Instead we should display a disabled "Update" button, so users understand that the update is available, but blocked by some condition. The tooltip should say something like "This plugin version requires SonarQube <required_version>".

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              stas.vilchik Stas Vilchik (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: