Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0, 2.0.1, 2.0.2
    • Fix Version/s: 2.1
    • Component/s: Connected Mode
    • Labels:
      None

      Description

      The connection done initially to /api/plugins/installed (to check plugins versions) causes the SonarQube server connect to the update center to fetch the plugins' categories.
      This might take a long time if the SonarQube server can't establish this connection due to network policies.
      See discussion here: https://groups.google.com/forum/?#!topic/sonarlint/hAdSiQNQq5s
      While a solution is being found for that WS, we should rely on /deploy/plugins/index.txt and parse each plugins' version (as it is already done for SQ < 5.2).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                duarte.meneses Duarte Meneses
                Reporter:
                duarte.meneses Duarte Meneses
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Due:
                  Created:
                  Updated:
                  Resolved: