Uploaded image for project: 'SonarLint For IntelliJ'
  1. SonarLint For IntelliJ
  2. SLI-562

Remove usage of APIs deprecated before 2019.3

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.2
    • Component/s: None
    • Labels:
      None

      Description

      Since we recently bumped our minimal supported version to 2019.3 in SLI-517, we could remove usages of APIs that have been deprecated prior to this version.

       

      The automated report from the marketplace mentions '13 usages of deprecated API. 4 override-only API usage violations'

        Attachments

          Activity

            People

            Assignee:
            julien.henry Julien Henry
            Reporter:
            damien.urruty Damien Urruty
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Due:
              Created:
              Updated:
              Resolved: