Uploaded image for project: 'SonarQube Scanner API'
  1. SonarQube Scanner API
  2. SCANNERAPI-66

For some HTTP requests done by the Sonar Runner to the Sonar server, the 'UserAgent' is sometimes missing

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3
    • Component/s: None
    • Labels:
      None

      Description

      [13/May/2013:14:36:46 +0000] "GET /sonar/api/server/version HTTP/1.1" 200 5 "-" "SonarRunner/2.2"
      [13/May/2013:14:36:46 +0000] "GET /sonar/batch_bootstrap/index HTTP/1.1" 302 136 "-" "SonarRunner/2.2"
      [13/May/2013:14:36:46 +0000] "GET /sonar/deploy/bootstrap/index.txt HTTP/1.1" 200 1816 "-" "SonarRunner/2.2"
      [13/May/2013:14:36:47 +0000] "GET /sonar/batch_bootstrap/properties?project=K4 HTTP/1.1" 200 3444 "-" "Sonar null/null"
      [13/May/2013:14:36:48 +0000] "GET /sonar/deploy/plugins/index.txt HTTP/1.1" 200 2278 "-" "Sonar null/null"
      [13/May/2013:14:36:52 +0000] "GET /sonar/deploy/jdbc-driver.txt HTTP/1.1" 200 64 "-" "Sonar null/null"
      [13/May/2013:14:37:06 +0000] "GET /sonar/api/server HTTP/1.1" 200 55 "-" "Sonar null/null"
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              henryju OLD - Julien HENRY
              Reporter:
              freddy.mallet Freddy Mallet (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: