Uploaded image for project: 'Parent OSS'
  1. Parent OSS
  2. PARENTOSS-58

Minimal required version of Maven should be 2.2.1

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 11
    • Labels:

      Description

      Currently minimal version set to 2.0, whereas according to versions-maven-plugin 1.3 we use plugins, which require at least 2.1.0.
      Versions up to 2.0.11 is for JDK 1.4, whereas our target - JDK 1.5.
      Moreover 2.1.0 and 2.2.0 cannot be used, because they produce incorrect checksums and GPG signatures.

      Also minimal version should be specified in "${project.prerequisites.maven}", because versions-maven-plugin relies on it (see MVERSIONS-169).

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            godin OLD - Evgeny Mandrikov
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: